Synchronisez votre Linux avec Hubic d'OVH

Publié initialement à : https://korben.info/synchronisez-linux-hubic-dovh.html

Éric, lecteur de Korben.info m’a gentiment proposé un script et un tuto permettant de mettre en place une synchro Rsync entre votre ordinateur ou votre serveur et Hubic, l’espace de stockage d’OVH. Comme le client officiel pour Linux est un poil mort-vivant, j’ai trouvé que c’était une bonne idée de partager ça ici avec vous,…

Bonjour,

Je vous conseille de regarder rclone (http://rclone.org) qui fait du rsync avec tous les clouds.

Je m’en sers régulièrement et il est vraiment génial, sauf peut-être sa vitesse.

Bonne bidouille

duplicati aussi.

Bonjour,

Je vais essayer rclone car je n’arrive à rien avec rsync. J’ai un “operation not permitted” alors qu’avec “cp” ça marche !!
Je ne monte pas le dossier Hubic en étant root. Le problème vient peut-être de là et j’ai du enlever l’option allow_other.

Xuo.

Bonjour,
Je n’utilise pas ce script sous root. Est-ce que le fait de mettre l’utilisateur dans groupe root temporairement règle le problème ?
Après vérification, je ne suis pas sous root, mais j’ai ajouté le droit “monter des systèmes de fichiers en espace utilisateur” dans le centre de contrôle de Gnome (utilitaire “Users And Groups”) pour mon utilisateur.

Bonjour,

J’ai le même problème en montant le dossier en étant root.
J’avais dit que ça passait avec la commande “cp” mais où j’avais picolé où ça ne passe plus.
Si je supprime le fichier sur Hubic avant de le copier depuis mon répertoire local vers Hubic, ça passe.
Je peux monter le système en étant utilisateur lambda avec le script de Korben. Les fichiers sont accessibles en écriture (de tête, ils sont en 666).
Il me manque peut-être une option subtile dans le montage distant. Je n’ai pas eu le temps de regarder la doc.

Xuo.

Ce que vous expliquez pour la nécessité de suppression avant copie est relatif aux limitations dont je parle dans le tuto. C’est une des limitations d’hubicfuse, ou plutôt d’hubic.

Bonjour,

Je n’ai pas vue de nécessité de supprimer des fichiers avant de les transférer dans le tuto.
Pour que j’arrive à avancer, j’ai fait 2 choses :

  • Dans le fichier .hubicfuse, je n’ai gardé que les champs client_id, client_secret, refresh_token et cache_timeout.
  • J’utilise les options suivantes pour rsync : -vrltHW --inplace --size-only

Mais j’ai aussi fait un “hubic full” que j’ai résolu en faisant un rm -rf default_segements/*. Je ne sais pas pourquoi j’ai eu droit à ça aussi.

Xuo.

1 J'aime

Bonjour,

les débits se sont ils améliorés ? J’ai eu la mauvaise expérience il y a 2 ans d’être bridé à 10Mbps en upload et download. C’était vraiment honteux de leurs part donc après cette mauvaise expérience mais aimé savoir si ce service inutilisable par le passé s’est amélioré.

Pour ma part j’ai vu du 18mbps sur ma connexion qui ne permet pas beaucoup plus en download, je monte à 8 mbps en upload, ce qui est le max de la connexion. Ils ont donc dû d’améliorer.

–inplace supprime de fait le fichier avant de le transférer. Il bypass le processus qui consiste à créer un fichier temporaire avant remplacement du fichier final.

Bonsoir,

Je ne sais pas quels étaient mes débits mais ils sont très faibles alors que je suis en fibre.
Je suis passé sur rclone et ça va vraiment plus vite qu’avec rsync + hubicfuse. Je vais rester sur rclone car a marche vraiment bien pour moi.

Xuo.