Korben, roi d’internet, logo bébé avec des lunettes en mode thug life

Comment installer TrueCrypt 7.1a sous macOS quand on rencontre l'erreur "TrueCrypt requires Mac OS X 10.4 or later." ?


#1

Publié initialement à : https://korben.info/comment-installer-truecrypt-7-1a-sous-macos-quand-on-rencontre-lerreur-truecrypt-requires-mac-os-x-10-4-or-later.html

J'ai voulu réinstaller TrueCrypt 7.1a sur mon macOS et après l'avoir téléchargé ici, je me suis heurté à l'erreur suivante :

TrueCrypt requires Mac OS X 10.4 or later.

Pas cool, sachant que la version actuelle de macOS est la 10.13.4.

Heureusement, il existe un moyen de contourner le problème. Voici comment.

Etape 1, copiez le fichier TrueCrypt7.1a.mpkg sur votre disque dur. Faites ensuite un clic droit dessus et faites "Afficher le contenu du paquet"

Rendez-vous ensuite dans le dossier "Contents" et éditer avec Textedit ou l'éditeur de texte de votre choix, le fichier distribution.dist.

Repérer ensuite les lignes que j'ai surligné dans la capture écran ci-dessous. Il s'agit du code qui vérifie la version de votre macOS et qui empêche TrueCrypt de s'installer. Vous pouvez supprimer tout ce que j'ai surligné ou simplement modifier les valeurs.

Sauvegardez le fichier, et relancez l'installation du package comme au début.

Problème résolu !


#2

https://apple.stackexchange.com/q/173879#173880 :thinking::thinking::thinking::thinking::thinking::thinking::thinking::thinking:


#3

https://www.veracrypt.fr/en/Downloads.html

Encore développé, forké et amélioré de TC.

Étonnant que tu ne connaisses pas.


#4

mettre simplement “<= 10.4.0” au lieu de ">= 10.4.0 suffirait peut-être ? En gardant un contrôle de version, plutôt que de tout supprimer ?

J’utilise Veracrypt, quelqu’un connait les différences exactes entre les deux ?


#5

Juste une question, et une seule … : Truecrypt ??? :scream::crazy_face:


#6

Korben le connait sans aucun doute puisque c’est de lui (Je crois me souvenir) que j’ai appris que Truecrypt c’était fini…


#7

TrueCrypt 7.1a reste pour moi aussi une valeur sur.

https://linuxfr.org/news/resume-de-l-affaire-truecrypt


#8

Pourquoi, tu proposes un tutoriel pour utiliser un logiciel de chiffrement qui n’est plus maintenu, depuis sa fermeture en 2014 par le FBI, suite à l’affaire du trafiquant de drogue internationale Paul Calder Le Roux qui a versé dans le développement et associé à E4M et TrueCrypt, il faut mieux utiliser le fork VeraCrypt le développeur s’appelle Mounir Idrassi, il a fait ses études à Polytechnique et à créer sa société Idrix, pourtant tu as déjà écrit un billet sur VeraCrypt.

Une petite question, soit tu n’as pas le temps avec des responsabilités professionnelles, soit tu vas passer ton Bac Pro de Boulanger en juin, je déconne, le petit troll du vendredi. :wink:

Voici les sources de Next Inpact (Dossier) et la presse généraliste pour l’histoire de Paul Calder Le Roux, c’est la presse anglaise qui a traité le plus sur ce sujet, en France je n’ai pas trouvé d’articles bizarrement, on pourrait en faire un livre puis un film avec une histoire pareille, amis les scénaristes une série sur Netflix, si Netflix veut, il faudrait négocier les droits.

Petit rappel au passage NextInpact est payant, mais il libère les articles au bout d’un mois pour les non-abonnés, personnellement j’ai un abonnement 5 € par mois sans engagement c’est toujours bien pour faire de la veille, Super Travail.

Interview de Mounir Idrassi et VeraCrypt à lire absolument.



Tutoriels de VeraCrypt




Concernant TruCrypt


Plus d’informations sur la version anglaise que la française de Wikipédia, vérifier les sources.


Concernant Paul le Roux








https://magazine.atavist.com/the-mastermind


#9

Il y a un ! devant la deuxième parenthèse. Donc ça dit : “Si version système n’est pas >= 10.4.0 alors erreurs …”
La bonne correction, plutôt que la suppression violente que propose Korben, serait :
if(!(system.version.ProductVersion >= ‘10.04.0’ )) {

parce que “10.4” c’est effectivement supérieur “10.13” du point de vue comparaison de chaînes de caractères.


#10

J’adore ! Dans l’article sur “TrueCrypt pour Windows contient deux failles, dont une critique”.

Il faut savoir cependant que ces failles ne remettent pas en question la sécurité de TrueCrypt lui-même, et donc de son chiffrement.

Faudrait savoir !


#11

Veracrypt j’en ai parlé en 2014. Mais va lire les commentaires des gens sur leur site . Apparemment, pas mal de pertes de données. Donc je ne l’utilise plus (d’où mon besoin de TrueCrypt)

https://korben.info/veracrypt.html


#12

Oups

https://korben.info/laudit-de-truecrypt-est-termine.html
il y a des failles au niveau de la génération de clé oui mais ça dépend de qui tu te protèges en fait. (NSA ou ton voisin)

Donc ça reste quand meme intéressant. Après des failles, il y en a partout dans tous les outils et ne pas les connaitre ne veut pas dire qu’elles n’existent pas :slight_smile: Donc autant partir sur le moins pire et le plus audité.


#13

Parce que j’avais besoin de TrueCrypt ponctuellement et que Veracrypt, j’ai pas confiance (cf mon autre message ici)