Korben, roi d’internet, logo bébé avec des lunettes en mode thug life

Windows 10 consomme tout le CPU de votre machine ? Voici une astuce pour régler le problème

#1

Originally published at: http://korben.info/windows-10-100-cpu.html

L’ami Dodutils m’a envoyé une astuce que je vais partager avec vous ici, et qui en sauvera certains. Si votre ordinateur sous Windows 10 souffle à fond, que la consommation de CPU est en permanence au taquet et que ça vous vide rapidement la batterie, c’est peut-être à cause du process qui gère la compression…

0 Likes

#2

Salut Korben,

Le problème d’utilisation viens d’une tâche planifiée qui test la RAM.

Start->Control Panel->Administrative Tools->Task Scheduler Task Scheduler Library->Microsoft->Windows->MemoryDiagnostic

Il faut désactiver : RunFullMemoryDiagnosticEntry

1 Like

#3

C’est Windows 10 (DIX), on est en 2017, on nous rebat les oreilles avec l’économie d’énergie depuis 30 ans… comment on peut avoir encore ce genre de problèmes de processus à la noix qui bouffe toute l’énergie pour rien ?

0 Likes

#4

Oui, oui le processus NTOSKRNL.EXE est un processus à la noix. C’est un des noyaux :confused:

Personnellement je n’ai pas ce problème et n’ai pas rencontré ce problème. malheureusement sous Windows force de croire que les personnes sont obligé de configurer leurs systèmes de manière boiteuse en pensant optimiser le système car lui ne sait pas comment faire. En gros vu que l’OS c’est de la merde, c’est à moi de décider comment configurer et donc au final bousiller l’ensemble et on se retrouve avec ce genre d’options à désactiver.

Il serait plus judicieux de voir pourquoi Windows ce comporte ainsi et pourquoi il démarre une tâche qui est censé ce démarré quand le PC est en idle… ( inactif)

Petite citation :

Prefetch/superfetch are used for a reason. If you think you can manage memory better than your OS, you’re sadly mistaken

0 Likes

#5

Bonjour tout le monde,

Le sujet d’actualité traitant des performances du système d’exploitation Windows ne date pas d’hier… Perso, quand j’utilise un OS Windows, je retire tout ce qui ne me sert pas pour préserver un niveau de “performance” optimal. Je pense que les performances d’une machine, en règle générale, sont intimement liées au budget financier alloué au matériel.

Par expérience, le niveau de performance d’une machine est souvent impacté par de mauvaises manipulations (accidentelles ou volontaires) utilisateurs, dont je fais parti ! :joy:

0 Likes

#6

il y a erreur sur la command !

ses pluto
Disable-MMAgent -mc et Enable-MMAgent -mc

https://superuser.com/questions/1000485/how-to-disable-windows-10-memory-compression

0 Likes

#7

C’est une reformulation, en un peu plus long, de ma question… et avec de la “merde” à la place des noix ! :smile:

0 Likes

#8

Désolé, je n’ai pu résister à exploiter ce jeu mots. D’un côté on peut blâmer Microsoft de vouloir faire bien et d’intégrer un processus qui contrôle les problèmes de mémoire et de l’autre ont peut également blâmer la personne qui à coder une application boiteuse et qui génère inutilement des erreurs dans l’EventLog.

En effet si on regarde les évènements déclencheur de la tâche planifiée, un des évènement est “Log: Application, Source: Application Error”, comme l’application n’est pas censé déclenché inutilement cette évènement alors Windows contrôle la mémoire. La résolution est donc soit :

  1. De modifier le comportement de Windows ?
  2. Corriger l’application fautive ?

Le dilemme est là et la meilleure solution c’est la 2,ou alors simplement supprimer les deux déclencheur (“Log: System, Source: Application Popup”, “Log: Application, Source: Application Error”) me semble la meilleur solution.

0 Likes

#9

Pour info, cette fonctionnalité, même si implémentée différemment, existe aussi dans Mac OS depuis Mavericks, semble causer des problèmes similaires, et peut également être désactivée si on le souhaite : http://superuser.com/questions/668114/disable-compressed-memory-in-mac-os-10-9-mavericks

0 Likes

#10

@madshiva
@tout le monde,

Puisqu’on parle de “trucs inutiles”, le plus simple dans ce cas serait de désactiver définitivement le service “Planificateur de tâches” Windows… Je crois que je viens d’allumer le “feu”, je prépare mon instructeur on ne sait jamais ! :grin:

0 Likes

#11

Erratum: extincteur ! :joy:

0 Likes

#12

Non ça n’est pas la même chose ce que tu vois comme tâche dans le planificateur (en fait il y en a deux) n’est pas la cause du problème (j’ai testé en les désactivant toutes les deux + reboot et le processus memory compression était toujours présent) et d’ailleurs si tu regardes les paramètres de lancement, ceux-ci sont conditionnels, autrement dit ne se lancent que de temps en temps sous condition(s) spécifique(s) et pas en permanence et c’est normal puisque ces deux tâches ne sont là que pour effectuer une vérification ponctuelle de la mémoire en cas de problème d’où le nom “memory diagnostic” hors le process qui bouffe c’est “memory compression”

0 Likes

#13

non -m tout court ça marche aussi comme tu peux le voir sur la capture d’écran

0 Likes

#14

C’est n’est pas cette tâche qui pose problème, là tu parles de Memory Diagnostic qui ne se lance que ponctuellement, hors c’est Memory Compression qui pose problème, beaucoup d’articles sur le Net confondent malheureusement les 2 et bien sûr de fil en aiguilles les “copieurs/suiveurs” reprennent bêtement l’info dans leurs propres articles sans chercher à effectuer leurs propres recherches/tests etc…

0 Likes

#15

Bonjour,

SOLUTION ALTERNATIVE OU COMPLÉMENTAIRE

Pour combattre les méfaits d’un processeur trop souvent au taquet sur un Asus T100 (Atom BayTrail), j’ai appliqué une autre recette qui consiste à faire apparaître et baisser les minimum et maximum alloués au processeur sur batterie (possible aussi sur secteur).

On trouve sur cette page quatre fichiers qui modifient la base de registre pour activer ou désactiver le réglage de ces minima / maxima.

https://www.eightforums.com/tutorials/51027-power-options-add-remove-min-max-processor-state.html?s=fd11f8868679f3f7a94480d28c93b160

On peut aussi créer manuellement ces réglages dans la base de registre.

Sans ces manipulations, le panneau “Paramètres avancés” des "Options d’alimentation"ne propose pas l’accès à ces réglages pour le processeur.

Personnellement, j’ai calé sur 1% le minima, et 99% le maxima qui empêche le processeur de passer en mode Turbo. Soit 1,6 GHz au lieu de 2,4 GHz. Garder bien sûr le maxima à 100% pour privilégier la performance. A chacun de faire ses tests, la page proposant 5% en minimum sur batterie.

Au repos, avec deux navigateurs web ouverts, et plusieurs onglets actif, luminosité à 25%, la jauge Batterybar m’annonce 8h30 d’autonomie.

Le gestionnaire de tâches est devenu bien plus calme…

Je suggère à Korben de faire un test, et s’il s’avère concluant, de repasser cette info dans le fil des news.

Bonjour chez vous.

Schol

1 Like

#16

Merci pour l’astuce. Ca a l’air cool, j’essayerai de tester quand je pourrai.

0 Likes

#17

@Schol
Bonsoir,

Étrange, sur une de mes machines (CPU i7 Skylake 6700 - OS Windows 8.1 Pro, carte mère Asus Z170 Gaming Pro) j’ai cette config de base par défaut (Min: 5% - Max: 100%):

Même en mode “Turbo” mon processeur ne cadence jamais au-delà des 3400 MHz, même en jouant sous “Battle Field 4”.

Tiens, ça me rappelle un soir, où pris de panique par le branle bas de combat des 6 ventilateurs de ma machine, j’ai bataillé pendant 30mn pour comprendre d’où venait le problème ! Tenez-vous bien. Vous allez rire :grin:

Les ventilateurs se sont arrêtés subitement sans que je puisse découvrir la cause de cette cacophonie ! Pris d’une envie soudaine de fumer une clope, j’ai ouvert la fenêtre de ma chambre…, quelle fut ma surprise quand j’ai enfin réussi à trouver la source du problème ! Le bruit venait en réalité de l’extérieur ! Des gars de la Mairie effectuaient des travaux. Haa! Haa!! :joy:

PS: Parfois on galère pour rien ! Il faut dire que je suis habitué aux “vieilles machines”, aujourd’hui tout est beaucoup plus silencieux.

Amicalement,
Diki

1 Like

#18

Ahaha sacrée anecdote :wink:

0 Likes

#19

Avec Win 7,sans "bidouilles"base de régistre…

0 Likes

#20

Eh, les gars, le sujet de départ, c’est Windows 10, pas Windows 7 ou 8.1 où ces réglages existent.

Dans Windows 1511, et Windows 1607 (anniversary update), sans les installer à la main, ils sont absents. Ou alors, c’est une disparition de type magie noire imputable aux drivers de mon Asus T100.

Après installation dans Windows 10, j’ai pu constater que j’avais 100% partout.

Bref, ces fichiers reg m’ont donc bien aidé à calmer le processeur. et mieux gérer ma batterie :slight_smile:

0 Likes